Your Ad Here

Recent Posts

Empty “Windows Features” after installing something in Windows 7

image

This problem has been bugging me for a while, a few of the reasons why I’m hesitant to use Windows 7. What usually happens after doing a clean install of Windows 7 is that I’d install ArcGIS Desktop and with it installation of a lot other software in the background. What I have noticed is that when done with the installation and doing a reboot, Windows feature would not display anything, windows features is empty or blank. This becomes a problem when you want to install something, say Safari, it will not complete the installation process. Even updates won’t install.

After spending more than 6 months with this problem, I got a little bit lucky and was able to find a solution. Now this solution is for x86 systems cause the problem does not exists in x64 versions of the operation system.

Here is the registry tweak you can use to solve this problem.

Step-by-Step Guide

  1. You need to run Registry Editor, to do that press and hold Windows Key in your keyboard and then the letter R.
  2. Type regedit in the Run Command window.
  3. Locate this key on the left pane 

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control  

  4. You should find this DWORD value on the right pane

    RegistrySizeLimit

  5. Double click on RegistrySizeLimit and paste the Decimal value of 4294967295 (ffffff in Hex).
  6. Close the Registry Editor and restart your pc.

Hope this helps. Any ideas on how to solve this problem is very much welcome! Cheers!

Related Posts by Category



4 Responses to "Empty “Windows Features” after installing something in Windows 7"

Anonymous Says :
Wed Feb 10, 08:29:00 AM GMT+8

Works! Thanks.

jonas Says :
Tue Jun 29, 01:52:00 AM GMT+8

I can't find the RegistrySizeLimit!

Borge Says :
Tue Jul 06, 12:20:00 AM GMT+8

@jonas you can always add the DWORD value RegistrySizeLimit then modify it's decimal value. It's just a matter of right clicking the registry editr.

Anonymous Says :
Sun Aug 01, 08:28:00 AM GMT+8

the problem exists also in x64 bit version of win 7 ultimate! now i try your method and i'll see if will works..

Post a Comment

Followers